This entry shows the step I took to set up a Cisco switch at work
Basic Switch Setup
Security
Lock down Cisco switch port to increase security
To assign an IP to a VLAN
Switch(config)#int vlan 1 Switch(config-if)#ip address 10.60.1.1 255.255.248.0 Switch(config-if)#no shut Switch(config-if)#end
Select multiple ports to configure
Switch1#enable
Switch1(config)#interface range gigabitEthernet 0/1 – 20
Switch1(config-if-range)#spanning-tree portfast
Switch1(config-if-range)#switchport mode trunk
Switch1(config-if-range)#^Z
Switch1# copy running-configuration startup-configuration
Switch1#show running-configuration
How to configure VTP Client and Server?
VTP (VLAN Trunking Protocol) is the protocol that propagates the information about which VLANs exist from one switch to another switch. If VTP did not provide this information, VLANs would have to be created on all switches individually in the network.
VTP is a Cisco proprietary protocol. The default mode of a switch is configured as VTP server. In any case, the server services are turned off, use the following command to turn it back on as VTP server.
- SwitchA#vlan database
- SwitchA(vlan)#vtp server
- SwitchA(vlan)#exit
First create multiple VLANs with name, assign multiple ports to them then create 802.1q trunk link between the two switches to allow communication between VLANs.
To create a VLAN, first enter global configuration mode to run the following commands.
Configuration to create VLAN 2 and 3 on switch A (VTP server)
SwitchA(config)#configure terminal (enter in global configuration mode)
SwitchA(config)#vlan 2(defining the vlan 2)
SwitchA(config)#vlan 2 name marketing (assigning the name marketing to vlan 2)
SwitchA(config)#vlan 3 (defining the vlan 3)
SwitchA(config)#vlan 3 name management (assigning the name management to vlan 3)
SwitchA(config)#exit (exit from vlan 3)
Now assigning the ports 2 and 3 to VLAN 2, it must be done from the interface mode. Enter the following commands to add port 2 and 3 to VLAN 2.
SwitchA(config)#configure terminal (enter in global configuration mode)
SwitchA(config)#interface fastethernet 0/2 (select the Ethernet 0 of port 2)
SwitchA(config-if)#switchport access vlan 2 (allot the membership of vlan 2)
SwitchA(config-if)#exit (exit from interface 2)
SwitchA(config)#interface fastethernet 0/3 (select the Ethernet 0 of port 3)
SwitchA(config-if)#switchport access vlan 2 (allot the membership of vlan 2)
SwitchA(config-if)#exit(exit from interface 3)
Now assigning the ports 4 and 5 to VLAN 3, enter the following commands to add port 4 and 5 to VLAN 3.
SwitchA(config)#configure terminal (enter in global configuration mode)
SwitchA(config)#interface fastethernet 0/4 (select the Ethernet 0 of port 4)
SwitchA(config-if)#switchport access vlan 3(allot the membership of vlan 3)
SwitchA(config-if)#exit(exit from interface 4)
SwitchA(config)#interface fastethernet 0/5 (select the Ethernet 0 of port 5)
SwitchA(config-if)#switchport access vlan 3 (allot the membership of vlan 3)
SwitchA(config-if)#exit (exit from interface 5)
Configuration of VTP client on switch B
SwitchB#vlan database
SwitchB(vlan)#vtp client
SwitchB(vlan)#vtp domain group1
SwitchB(vlan)#exit
Trunking with 802.1q
Now create 802.1q trunk link between the two switches to allow communication between VLANs.
On both switches, SwitchA and SwitchB type the following command with 802.1q at the fastethernet 0/1 interface.
SwitchA(config)#configure terminal (enter in global configuration mode)
SwitchA(config)#interface fastethernet 0/1 (select the Ethernet 0 of port 1)
SwitchA(config-if)#switchport mode trunk (set port 1 as trunk port)
SwitchA(config-if)#switchport trunk encapsulation dot1q
SwitchA(config-if)#end (exit from interface 1)
SwitchB(config)#interface fastethernet 0/1(select the Ethernet 0 of port 1)
SwitchB(config-if)#switchport mode trunk(set port 1 as trunk port)
SwitchA(config-if)#switchport trunk encapsulation dot1q
SwitchB(config-if)#end (exit from interface 1)
- To verify that fastethernet 0/1 has been established as trunk port, type the show interface fastethernet 0/1 switchport at the privileged EXEC mode.
- Although the VLAN definitions have migrated to the switch B using VTP, but it is necessary to assign ports to these VLANs on switch B.
- Now assigning the ports 2 and 3 to VLAN 2, it must be done from the interface mode. Enter the following commands to add port 2 and 3 to VLAN 2.
SwitchB(config)#configure terminal
SwitchB(config)#interface fastethernet 0/2 (select the Ethernet 0 of port 2)
SwitchB(config-if)#switchport access vlan 2 (allot the membership of vlan 2)
SwitchB(config-if)#exit (exit from interface 2)
SwitchB(config)#interface fastethernet 0/3 (select the Ethernet 0 of port 3)
SwitchB(config-if)#switchport access vlan 2 (allot the membership of vlan 2)
SwitchB(config-if)#exit (exit from interface 3)
Now assigning the ports 4 and 5 to VLAN 3, enter the following commands to add port 4 and 5 to VLAN 3.
SwitchB(config)#configure terminal (enter in global configuration mode)
SwitchB(config)#interface fastethernet 0/4 (select the Ethernet 0 of port 4)
SwitchB(config-if)#switchport access vlan 3 (allot the membership of vlan 3)
SwitchB(config-if)#exit (exit from interface 4)
SwitchB(config)#interface fastethernet 0/5 (select the Ethernet 0 of port 5)
SwitchB(config-if)#switchport access vlan 3 (allot the membership of vlan 3)
SwitchB(config-if)#exit (exit from interface 5)
I don’t ordinarily comment but I gotta tell regards for the post on this one : D.
Keep functioning ,splendid job!
I like your site plain and simple. Keep up the good work and I will keep coming back.
dude. your blog is wonderful just like my blog”
How do I know if a WordPress theme supports a subscribe option?
Pretty impressive post. I just stumbled upon your site and wanted to say that I have really enjoyed reading your opinions. Any way Ill be subscribing to your feed and I hope you post again soon.
Yo. Actually needed to make a quick comment and enquire where you came across your particular web graphics I might be opening own page and tremendously appreciate your personal template.
Maybe there is a problem with the Style sheet here? I can’t make out anything here without highlighting it with the mouse, due to the fact it’s all purple. I’m using Chrome if it makes a difference.
I absolutely love the layout on this webpage. Could you let me know where you can get it? Thanks!
I just want to tell you that I am new to blogging and seriously enjoyed your web page. Almost certainly I’m want to bookmark your website . You surely come with really good articles. Kudos for sharing your blog site.
I’d have to check with you here. Which is not something I usually do! I enjoy reading a post that will make people think. Also, thanks for allowing me to comment!
you have a great blog here! would you like to make some invite posts on my blog?
I simply want to mention I am just very new to blogging and site-building and truly loved you’re web blog. Almost certainly I’m going to bookmark your site . You really have outstanding articles. Regards for sharing your blog.
The intelligible answer